I have Android 2.2, but is not compatible with my phone